Nix shell with all needed dependencies for developing

Put this into your current working directory and run

nix-shell

. It will spawn a shell with havng all needed Geany dependencies as well as with Geany itself inside $PATH.

shell.nix
let
  pkgs = import <nixpkgs> {};
in
 
pkgs.mkShell {
 
packages = [
  pkgs.file
  pkgs.gtk3
  pkgs.hicolor-icon-theme
  pkgs.intltool
  pkgs.libintl
  pkgs.which
  pkgs.wrapGAppsHook
  pkgs.pkg-config
  pkgs.automake
  pkgs.autoreconfHook
  pkgs.docutils
  pkgs.geany.all
];
}
Print/export